Locked up!

Eyedoc

New member
Joined
Feb 23, 2020
Messages
2
Reaction score
2
Points
3
Location
Virginia Beach
Hey guys. I never post reviews. Just not my thing. But hoping Weber checks these and can see our frustrations. Went out on a limb and bought the larger smokefire knowing it was a new untested model. (My wife told me not to do it). Upgraded ALL the firmware, and did the burn in fine yesterday morning, had a 12lb Boston butt all rubbed up. Started the grill to 225 last night at 11pm. Put the big ol butt on, checked my connect app, and went to bed. Woke up at 2am to pee. App still said.holding steady at 225. Went back to bed. Got up at 7am and checked the app. Still said 225 and looking good. Happy man. Went downstairs to make coffee and spritz my glorious smelling pork. Nope. Ice cold! Grill said 225, app said 225. Grill and meat ice cold and all electronics locked up. Had to turn the switch off and back on to even get it to respond. NO notification that there was a problem cause the whole thing just locked up. Now it's 8am, I've got a 12 lb ice cold piece of meat, friends coming for lunch, a wife looking at me with that "told ya so" face, and I'm pissed. Started it up again to try one last time. Glitches need to be fixed Weber! Pissed at the beach.
20200223_073851.jpg
20200223_073856.jpg
 

abmet

Well-known member
SOTM Winner
Joined
Feb 11, 2020
Messages
836
Reaction score
803
Points
93
Location
Missouri
That sucks, sorry you had that issue. I would contact Weber support, maybe you have a faulty controller.
 

GriLLMaRksRseXy

Well-known member
Joined
Feb 11, 2020
Messages
227
Reaction score
261
Points
63
Location
Tallahassee, FL
Hey guys. I never post reviews. Just not my thing. But hoping Weber checks these and can see our frustrations. Went out on a limb and bought the larger smokefire knowing it was a new untested model. (My wife told me not to do it). Upgraded ALL the firmware, and did the burn in fine yesterday morning, had a 12lb Boston butt all rubbed up. Started the grill to 225 last night at 11pm. Put the big ol butt on, checked my connect app, and went to bed. Woke up at 2am to pee. App still said.holding steady at 225. Went back to bed. Got up at 7am and checked the app. Still said 225 and looking good. Happy man. Went downstairs to make coffee and spritz my glorious smelling pork. Nope. Ice cold! Grill said 225, app said 225. Grill and meat ice cold and all electronics locked up. Had to turn the switch off and back on to even get it to respond. NO notification that there was a problem cause the whole thing just locked up. Now it's 8am, I've got a 12 lb ice cold piece of meat, friends coming for lunch, a wife looking at me with that "told ya so" face, and I'm pissed. Started it up again to try one last time. Glitches need to be fixed Weber! Pissed at the beach. View attachment 238View attachment 239
Same issue with mine during initial burn in. At least mine stayed running but controller was unresponsive. Havent had any issues since then with it. I'm still going to contact weber once I finish my list so I can knock them all out at once with them.
 

Latest Discussions

Top