I am scared

JohnHarley

New member
Joined
Feb 16, 2020
Messages
2
Reaction score
2
Points
3
Location
Virginia
I have been watching YouTube and seeing problems with the new SmokeFire, I haven’t got mine yet, it’s been stuck in Charlotte for the past several days. I hope Webber will work with everyone that is having problems with theirs. I wonder if I should send it back.
 

FredSC

Active member
Joined
Feb 15, 2020
Messages
106
Reaction score
146
Points
43
Location
South Carolina
I would like to think with their great repetition Weber will get these things worked out. Also maybe removing the guard will fix the problem. Also it maybe folks on here come up with some things that solve the problem as well. It will be interesting to hear what weber has to say about the cavities forming in the hopper. I would think they had to see this during their trail runs. They have a lot at stake with their repetition here. I will say the ribs and steaks I have done so far taste wonderful. I will be sure to post the replies I get from Weber support.
 

Billybo

Member
Joined
Jan 21, 2020
Messages
72
Reaction score
97
Points
18
Location
Ontario, Canada
I have been watching YouTube and seeing problems with the new SmokeFire, I haven’t got mine yet, it’s been stuck in Charlotte for the past several days. I hope Webber will work with everyone that is having problems with theirs. I wonder if I should send it back.
I’m still waiting on mine and the problems are making me a bit nervous. With that said, I willing to bet some problems can be chocked up to user error but there does definitely seem to be some issues with both the software and the pellet feeding. I’m torn to be honest and am watching the user feedback closely as well as Weber’s response to the issues. I find it difficult to fathom that they didn’t catch the pellet feeding issue in their testing.
 

Brian Vallotton

Active member
Joined
Feb 4, 2020
Messages
244
Reaction score
181
Points
43
Location
Manteca CA
I’m still waiting on mine and the problems are making me a bit nervous. With that said, I willing to bet some problems can be chocked up to user error but there does definitely seem to be some issues with both the software and the pellet feeding. I’m torn to be honest and am watching the user feedback closely as well as Weber’s response to the issues. I find it difficult to fathom that they didn’t catch the pellet feeding issue in their testing.
I agree completely and I am a bit nervous too. Mine should be in this week.
 

BadAss BBQ

Member
Joined
Feb 15, 2020
Messages
20
Reaction score
29
Points
13
Location
North Vancouver, BC
I'm in the same boat, move over! I've been wrestling with telling SEKO to send it back prior to delivery but my experience with Weber over the years has been great and if Weber decided to make the preorder gang their beta testers at least its real time feedback. I'm sure the posts will fly in the next couple of days with Weber dealing with all these issues like they have in the past.
 

Brian Vallotton

Active member
Joined
Feb 4, 2020
Messages
244
Reaction score
181
Points
43
Location
Manteca CA
I'm in the same boat, move over! I've been wrestling with telling SEKO to send it back prior to delivery but my experience with Weber over the years has been great and if Weber decided to make the preorder gang their beta testers at least its real time feedback. I'm sure the posts will fly in the next couple of days with Weber dealing with all these issues like they have in the past.
Glad you are here! This forum is fun and very useful.
 

Dubs

Member
Joined
Feb 15, 2020
Messages
51
Reaction score
56
Points
18
Location
Illinois
Mine's still in the box ready to go back to Lowe's unless we start hearing and seeing some better results, performance and what Weber has to say. Software issues are not a huge concern to me as those should be quickly fixed, but my biggest worry is these grills have design or component issues, that are not an easy fix.
 

Brian Vallotton

Active member
Joined
Feb 4, 2020
Messages
244
Reaction score
181
Points
43
Location
Manteca CA
Mine's still in the box ready to go back to Lowe's unless we start hearing and seeing some better results, performance and what Weber has to say. Software issues are not a huge concern to me as those should be quickly fixed, but my biggest worry is these grills have design or component issues, that are not an easy fix.
The one that bothers me the most is the auger feed issue. How could that have been overlooked? They must of known about it. It will be interesting to see how these issues get worked out. I do believe that they will.
 

Dubs

Member
Joined
Feb 15, 2020
Messages
51
Reaction score
56
Points
18
Location
Illinois
That auger is concerning, also I think they may have missed the mark on the vents in the back. Seems like with this grill you have to be extremely careful with where you position it based on wind direction and letting in the cold. Maybe they can fasten and sell(give) some accessory that helps block the wind (should have been noticed in R&D). Really curious on all the testing they did. Was it a bunch of their chefs cooking in the 72deg windless environment of their restaurant.
 

CEd4jets

Active member
Joined
Feb 14, 2020
Messages
127
Reaction score
124
Points
43
Location
So FL
For those who have had the pellet feed problem, is it a matter of the pellets getting stuck in the safety screen above the auger? I assume, could be wrong that the screen is there to prevent someone from sticking their finger in The auger. Ouch! and would be a crazy thing to do.
 

Dubs

Member
Joined
Feb 15, 2020
Messages
51
Reaction score
56
Points
18
Location
Illinois
Baby Back Maniac just posted his first review on the EX6 and was having pellet issues.
 

Jesse749

Member
Joined
Feb 7, 2020
Messages
32
Reaction score
68
Points
18
Location
Oklahoma
For those who have had the pellet feed problem, is it a matter of the pellets getting stuck in the safety screen above the auger? I assume, could be wrong that the screen is there to prevent someone from sticking their finger in The auger. Ouch! and would be a crazy thing to do.
Yes, it seemed like the screen was causing the pellets to jam up and therefore not feed into the auger.
 

Latest Discussions

Top