Grilled a Turkey Breast today at 375 degrees, no issues with the pellet feed

FredSC

Active member
Joined
Feb 15, 2020
Messages
106
Reaction score
146
Points
43
Location
South Carolina
Hi folks,

Decided to leave guard over auger in place for the moment, I wanted to see if having a full hopper had any influence on the pellet feed. But since I was cooking at a higher temperature, it could also be that the auger moving slightly faster provided enough movement of the pellets to keep a bridge from forming with the pellets over the auger opening. So still a bit of mixed results. In hind sight I should have smoked the breast at a lower temp, instead of cooking at a higher temperature.
Grill held the set point well.
Using the probe was a little bit of a learning curve, you don't plug the probe in until after you set the desire goal in the app.
Again no alarm or notification when the breast reach 165, so if I had not been watching the app, it would have gone right on.
Weber has lots of works to do on the app, very disappointed. I'm using the IOS app, if someone has andriod it would be nice to hear if the app is any better.
So up coming plans, this weekend is to sear some scallops and thinking about getting a pork loin or some type of beef roast for low and slow and see if there are problems with the pellet feed at the lower temp, using a full hopper.
No feedback from Weber on my communication.
I'm sure they are getting an ear full.

FSC
 

Attachments

topkatt4518

Member
Joined
Feb 11, 2020
Messages
27
Reaction score
39
Points
13
Location
NJ
Morning
Android app has the same piss-poor issues that the IOS does. Cooked a pork butt and if I did not check the temps every 15 min it was just going past the setpoint. It is a good thing I had my ThermoPro hooked up and that alerted me. By the way the ThermoPro and Weber probes are interchangeable. I tested them last night in an ice bath and both reacted exactly the same. So you can use the Weber sensors in the ThermoPro or visa-versa if you have extra ones or one fails.
 

UGator

Member
Joined
Jan 25, 2020
Messages
25
Reaction score
39
Points
13
Location
Johns Creek, GA
Morning
Android app has the same piss-poor issues that the IOS does. Cooked a pork butt and if I did not check the temps every 15 min it was just going past the setpoint. It is a good thing I had my ThermoPro hooked up and that alerted me. By the way the ThermoPro and Weber probes are interchangeable. I tested them last night in an ice bath and both reacted exactly the same. So you can use the Weber sensors in the ThermoPro or visa-versa if you have extra ones or one fails.
I agree with the topkatt - the Android app is terrible. I thought weber put more emphasis on developing one app vs the other, but it appears that they chose to treat both equally - in a bad way:mad:
 

Latest Discussions

Top