EX6 Success!

mtomas

Member
Joined
Dec 18, 2019
Messages
15
Reaction score
25
Points
13
Location
Safety Harbor, FL
Hey all! Did my initial 600 degree burn-in for 45 mins on Friday night, and did my first cook today. Problems with the app with standing (more on this below), I'm pleased to report that everything went remarkably smooth and worked very very well!

The burn-in process got up to 600 very quickly, supported a change to a lower temp afterwards and shut down without a single hiccup. No freezing or nothing, behaved completely as expected.

For the first cook, I did a pork butt for 9 and 1/2 hours @ 250. Also threw in a rack of baby backs a little more than halfway through. Zero problems throughout. Temp held very steady, no controller freezes, everything was good. The best part - flavor was amazing and the smoke was every bit as good as my WSM!

I haven't done a formal test to check temperature variation across the grilling surface yet, but I'm not sure i care based on how good the food came out 😆

As far as pellet consumption is concerned, the burn-in plus the nine and 1/2 hour cook used about 97% of one full bag of the Weber grillmaster blend pellets.

The only issue I'm having so far is related to the app. I cannot get it to pair via Bluetooth to any of my Android phones or my Android tablet so I can't get the first firmware update, connect via Wi-Fi, or monitor temps remotely. I am engaged with Weber support on this so hopefully it will get worked out soon.

Sorry for such a long post... But with all the concerning commentary I'm seeing on the internet, I figured it would be helpful to show a positive story as well 👍
 

primeone

Administrator
Staff member
Joined
Nov 23, 2019
Messages
266
Reaction score
270
Points
63
Location
Austin, TX
Thanks for the feedback, glad your first cook turned out great!

Did you wrap the pork butt at all or leave it unwrapped the entire time?
 

Brian Vallotton

Active member
Joined
Feb 4, 2020
Messages
244
Reaction score
181
Points
43
Location
Manteca CA
Hey all! Did my initial 600 degree burn-in for 45 mins on Friday night, and did my first cook today. Problems with the app with standing (more on this below), I'm pleased to report that everything went remarkably smooth and worked very very well!

The burn-in process got up to 600 very quickly, supported a change to a lower temp afterwards and shut down without a single hiccup. No freezing or nothing, behaved completely as expected.

For the first cook, I did a pork butt for 9 and 1/2 hours @ 250. Also threw in a rack of baby backs a little more than halfway through. Zero problems throughout. Temp held very steady, no controller freezes, everything was good. The best part - flavor was amazing and the smoke was every bit as good as my WSM!

I haven't done a formal test to check temperature variation across the grilling surface yet, but I'm not sure i care based on how good the food came out 😆

As far as pellet consumption is concerned, the burn-in plus the nine and 1/2 hour cook used about 97% of one full bag of the Weber grillmaster blend pellets.

The only issue I'm having so far is related to the app. I cannot get it to pair via Bluetooth to any of my Android phones or my Android tablet so I can't get the first firmware update, connect via Wi-Fi, or monitor temps remotely. I am engaged with Weber support on this so hopefully it will get worked out soon.

Sorry for such a long post... But with all the concerning commentary I'm seeing on the internet, I figured it would be helpful to show a positive story as well 👍
So good to hear this! Yippee!!
 

Latest Discussions

Top